PROBLEMA

No se puede iniciar CityEngine a través de una conexión de escritorio remoto debido a un error de OpenGL

Last Published: April 25, 2020

Descripción

CityEngine no se inicia cuando se accede desde una conexión de escritorio remoto.

Causa

Esto ocurre porque CityEngine requiere OpenGL 2.x para renderizar gráficos. El escritorio remoto (RDP) no admite OpenGL en equipos cliente superiores a 1.1. Por lo tanto, cuando CityEngine se inicia mediante una conexión de escritorio remoto, la visualización se acopla con OpenGL 1.x, lo que hace que muestre el siguiente error.

Abrir versión GL CityEngine requiere al menos OpenGL 2.0. Su versión actual (OpenGL 1.1.0, Microsoft Corporation GDI Generic) no es compatible. Actualice sus controladores o póngase en contacto con el soporte técnico.

[O-Image] Error de OpenGL

Esto ocurre incluso cuando el equipo físico en el que está instalado CityEngine tiene una versión aceptable de OpenGL.

Solución o solución alternativa

Existen dos enfoques posibles para resolver este problema.
  • Iniciar CityEngine en el equipo antes de iniciar una conexión de escritorio remota
O bien,
  • crear un archivo de lotes para desconectar la sesión de escritorio remoto e iniciar automáticamente CityEngine en el equipo

Ejemplo de archivo de lotes:

#Utilizar sesión de consulta en cmd para determinar el Id. de sesión, normalmente 1 #El usuario que ejecuta RDP debe ser un administrador. #Esto desconecta RDP tscon 1 /dest:console #Esto inicia CityEngine start "CE" "C:\Archivos de programa\ESRI\CityEngine\CityEngine.exe"

Ahora se pueden realizar conexiones a través de RDP y CityEngine se inicia.

Id. de artículo:000012119

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema