ERROR

El programa no puede iniciarse porque falta LayerUILib.dll en el equipo. Pruebe a volver a instalar el programa para solucionar este problema

Last Published: April 25, 2020

Mensaje de error

Al iniciar ArcMap 10.2.x puede ocurrir el siguiente error:

"El programa no puede iniciarse porque falta LayerUILib.dll en el equipo. Pruebe a volver a instalar el programa para solucionar este problema"
[O-Image]

Causa

Este problema ocurre si el archivo LayerUILib.dll falta o está dañado de una instalación anterior.

Solución o solución alternativa

Existen dos métodos para abordar este problema, como se describe a continuación.

Método 1: Reparar el software de ArcGIS

1. Vaya a C:\Archivos de programa(x86)\ArcGIS\Desktop10.2.x\bin.
2. Si existe el archivo LayerUILib.dll, cambie el nombre del archivo a LayerUILib.OLD.
3. Haga clic en el menú Inicio de Windows > Panel de control > Programas > Programas y características.
4. Haga clic con el botón derecho en ArcGIS 10.2.x for Desktop y haga clic en Desinstalar / Cambiar.
5. En el cuadro de diálogo de instalación de ArcGIS 10.2.x for Desktop, seleccione Reparar y continúe con la instalación hasta completarla.
[O-Image]
6. Inicie ArcMap.

Si la solución anterior no resuelve el problema, ejecute una desinstalación limpia del software de ArcGIS.

Método 2: Desinstalar y volver a instalar el software de ArcGIS

Advertencia:
Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Se recomienda que realice una copia de seguridad del sistema operativo y los archivos, incluido el registro, antes de continuar. Si es necesario, consulte con un profesional en sistemas informáticos cualificado.
Esri no puede garantizar resultados por modificaciones incorrectas cuando sigue estas instrucciones. Por tanto, utilícelos asumiendo el riesgo correspondiente.


1. Haga clic en el menú Inicio de Windows > Panel de control > Programas > Programas y características.
2. Haga clic con el botón derecho en ArcGIS 10.2.x for Desktop y haga clic en Desinstalar / Cambiar.
3. En el cuadro de diálogo de instalación de ArcGIS for Desktop, seleccione Quitar y continúe con la desinstalación hasta completarla.


[O-Image]
4. Elimine las siguientes carpetas:


C:\Archivos de programa (x86)\ArcGIS\Desktop10.2
C:\ProgramData\FLEXnet


5. Elimine las siguientes claves de registro:

Código:
HKEY_LOCAL_MACHINE\SOFTWARE\ESRI
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI


6. Vuelva a instalar el software de ArcGIS

Id. de artículo:000012072

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Descubrir más sobre este tema