PROBLEMA

ArcGlobe deja de responder en Generar módulo ArcID y no se abre

Last Published: December 1, 2020

Descripción

Después de instalar ArcGIS Desktop, ArcGlobe a veces deja de responder con el mensaje "Generando módulo ArcID". El Administrador de tareas revela que ArcGlobe.exe se está ejecutando y consume tiempo de procesador, pero la aplicación no se abre.

Nota: Este artículo solo pertenece a las versiones 10.0 y anterior de ArcGIS Server. Es posible que versiones posteriores de ArcGIS incluyan funcionalidades distintas, así como nombres y ubicaciones distintos para menús, comandos y herramientas de geoprocesamiento.

Causa

En equipos con varios núcleos de procesador, uno o varios de los núcleos pueden funcionar a la máxima capacidad, mientras que el otro no lo hace. En estos casos, si la carga de trabajo del procesador no se puede redistribuir, ArcGlobe no se abrirá completamente. Finalizar el proceso ArcGlobe.exe no hace que la carga de trabajo del procesador se redistribuya de forma automática correctamente.

Advertencia: En las siguientes instrucciones se modifican componentes críticos de su sistema operativo. Se recomienda que realice una copia de seguridad del sistema operativo y de los archivos, incluido el registro, antes de continuar. Si es necesario, consulte con un profesional en sistemas informáticos cualificado. Esri no puede garantizar los resultados derivados de modificaciones incorrectas al seguir estas instrucciones; por tanto, tenga cuidado y continúe bajo su propio riesgo.

Solución o solución alternativa

Para evitar este problema, siga los pasos que se describen a continuación para deshabilitar y volver a habilitar la compatibilidad con multiprocesador.

Para Windows 2000, Windows XP y Windows 2003:

  1. Edite el archivo Boot.ini del equipo para deshabilitar la compatibilidad con multiprocesador.
  2. Haga clic con el botón derecho en Mi equipo y seleccione Propiedades.
  3. En la ventana Propiedades, haga clic en la pestaña Opciones avanzadas.
  4. En el área Inicio y recuperación, haga clic en el botón Configuración.
  5. Junto a la etiqueta Para editar manualmente el archivo de opciones de inicio, haga clic en Editar, pulse Editar.
  6. En el archivo Boot.ini, agregue la opción /numproc=1 después de la opción /fastdetect. Haga clic en Archivo > Guardar. Cierre el archivo Boot.ini.
  7. Reinicie el equipo. Después de reiniciar el equipo, abra ArcGlobe. Debería abrirse sin problemas.
  8. Después de abrir correctamente ArcGlobe, cierre la aplicación. Siga los pasos 1-3 anteriores y elimine la opción /numproc=1 después de la opción /fastdetect y guarde el cambio.
  9. Reinicie de nuevo el equipo. ArcGlobe ahora debería abrirse y funcionar correctamente sin problemas adicionales.

En Windows Vista y Windows Server 2008, no hay ningún archivo Boot.ini. En su lugar, el número de procesadores disponibles al iniciar el sistema se puede definir en Opciones de arranque avanzadas en la herramienta Configuración del sistema de Windows.

  1. En el escritorio de Windows, pulse el botón Inicio y seleccione EJECUTAR.
  2. En el cuadro EJECUTAR, escriba MSCONFIG y pulse [Intro].
  3. Se abre la herramienta Configuración del sistema de Windows. En la herramienta Configuración del sistema, seleccione la pestaña Arranque y haga clic en el botón Opciones avanzadas.
  4. En el cuadro de diálogo Opciones avanzadas de arranque, active la casilla situada junto a Número de procesadores para activar el menú desplegable Número de procesador y seleccione 1 como el número de procesadores disponibles.
  5. Reinicie el equipo. ArcGlobe ahora debería abrirse y funcionar correctamente sin problemas adicionales.
  6. Después de abrir correctamente ArcGlobe, cierre la aplicación. Siga los pasos del 8 al 10 de la sección anterior, pero cambie el número de procesadores disponibles al valor original.
  7. Reinicie de nuevo el equipo. ArcGlobe ahora debería abrirse y funcionar correctamente sin problemas adicionales.

Id. de artículo:000010286

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Descubrir más sobre este tema