ERROR

ArcMap.exe encontró un error y necesita cerrarse. Disculpe las molestias.

Last Published: January 31, 2024

Mensaje de error

ArcMap or ArcCatalog randomly crashes and Windows returns one of the error messages shown below:

Error:
ArcMap.exe has encountered an error and needs to close. We apologize for the inconvenience.
Error:
The instruction at 0x000xx00 referenced memory at 0x000000. The memory could not be 'read'. Click OK to terminate the program.

The instructions provided in this article address general solutions that may help avoid the above errors.

Causa

This error can be caused by one or more system conflicts.

Note:
If this error occurs when performing a specific operation, check the Related Information section below for an article that addresses the situation. If the instructions in this article do not resolve the problem, and there is not an article related to your issue, please contact Esri Support Services.

Solución o solución alternativa

The following is a list of the most common solutions to this error. Please note that this is a general Windows error that has many causes and many solutions. Contrary to the error message, there is no log file created.

Rename the normal template for the application that generates the error

  1. Close any ArcCatalog or ArcMap sessions that are running.
  2. In File Explorer, browse to:
C:\Users\<user name>\AppData\Roaming\ESRI
Note:
The Application Data or AppData folder is hidden by default. If this folder is not visible, navigate to Tools > Folder Options > View tab, and select the option to show hidden files and folders.
  1. Open the folder for the component of ArcGIS, ArcCatalog or ArcMap that is generating the error message. Each component of the software has a template that stores settings and customizations for that part of ArcGIS. These are:
    • ArcCatalog: normal.gxt
    • ArcMap: normal.mxt, stored in the Templates folder
    • ArcToolbox: arctoolbox.dat
  2. Rename the file (for example: OLDNORMAL.GXT). When that component of ArcGIS is started again, a new template is created. This resolves many problems with ArcGIS software.
Change the TEMP environment variable for Windows
  1. Verify the following user variables are set:
Variable: TMP Value: <drive>:\TEMP
Variable: TEMP Value: <drive>:\TEMP
  1. Set the environment variable based on the operating system.

Clean out the TEMP directory

Browse to:

C:\Users\<your user name>\AppData\Local\Temp

This directory can become filled with hundreds or thousands of files and folders.
After resetting TEMP and TMP as described in the previous step and rebooting the computer, go to the original TEMP directory at the path above and delete all of the files and folders. Deleting the files in the new TEMP directory on a regular basis is also recommended to maintain good performance.

Verify that a default printer is installed

Check that the default printer is a valid, working printer by doing a test print. If the default printer is on a network, be sure there is access to that printer. If no printers are installed, install a test default printer.

Remove any customizations, add-on scripts, and third-party extensions for ArcGIS and unregister any custom DLLs that may be present
If removing all customizations fixes the problem, then the customizations can be added one at a time to determine which one is causing the problem.

Note:
Methods to remove customizations vary depending on the customization type. Contact the vendor or author of the customization to determine the best method.

Maximize the virtual memory for the operating system
Verify that a minimum of 500 MB of virtual memory is present. The initial and maximum size can be set as high as three times the computer's RAM, up to 6GB or approximately 6,144 MB.
How to Increase Virtual Memory in Windows 10: A Quick Guide

Verify that the operating system is up-to-date
Go to the Update Windows 10 web page to check for updates.

Run a repair of the ArcGIS Desktop software

  1. Navigate to Control Panel > Programs > Programs and Features.
  2. Right-click the ArcGIS Desktop program and select Uninstall/Change. The Program Maintenance text box window will open.
  3. Select Repair. Click Next, then click Install.

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