ERROR

1021: El token ha caducado

Last Published: January 4, 2021

Mensaje de error

Al implementar WS-Security como mecanismo de autenticación en el acceso a ArcWeb Services, puede aparecer el siguiente mensaje de error:

Error: 1021: El token ha caducado
Nota: La información de este artículo se aplica a un producto retirado, ArcWeb Services.

Causa

El reloj del equipo cliente no está sincronizado con el reloj de los servidores de ArcWeb.

Solución o solución alternativa

Sincronice el reloj del equipo cliente con la hora estándar mantenida por algunos servidores Network Time Protocol (NTP). El Instituto Nacional de Normalización y Tecnología (NIST) de Estados Unidos mantiene servidores horarios.

Antes de comenzar

  1. Compruebe la hora de su equipo con la difusión NIST WWV. Consulte el siguiente artículo técnico: Cómo: Verificar la hora del equipo con el Instituto Nacional de Normalización y Tecnología para obtener instrucciones.
  2. Revise la información disponible en National Institute of Systems and Technology Internet Time Service.
  3. Seleccione el servidor NIST Internet Time Service (ITS) más cercano a su ubicación: tabla Internet Time Service.
  4. Siga el procedimiento seleccionando a continuación las instrucciones que correspondan a su dominio.

Equipos con Windows 2000 o Windows XP en una red corporativa (dominio)

  1. Póngase en contacto con el administrador del sistema para verificar si su equipo forma parte de un dominio; de ser así, no es necesario hacer nada más, dado que los relojes de los equipos se pueden ajustar automáticamente a un tiempo exacto. Continúe con los siguientes pasos si mantiene relojes para una red o si es una persona dentro de una red que necesita visualizar una hora muy precisa en su equipo.
  2. Abra la línea de comandos haciendo clic en Inicio > Todos los programas > Accesorios > Línea de comandos.
  3. Escriba este comando:
    net time /setsntp:{Server Address}
    "Server Address" es la selección que realizó en el paso 3 anterior. Por ejemplo: net time /setsntp:nist1-ny.glassey.com
  4. Reinicie el servicio Hora de Windows para reflejar el cambio en la configuración.
    1. Abra Inicio > Todos los programas > Panel de control > Herramientas administrativas > Servicios. Seleccione el servicio Hora de Windows y abra su cuadro de diálogo de propiedades haciendo clic con el botón derecho en él.
    2. Haga clic en los botones Detener e Iniciar para reiniciar el servicio.
Nota: Para volver a la configuración original, utilice el siguiente comando: net time /setsntp Para saber qué servidor NTP externo utilizará el servicio w32time cuando se inicie de nuevo, utilice el siguiente comando: net time /querysntp

Equipos con Windows 2000 o Windows XP no en una red corporativa (dominio)

  1. Abra el Panel de control de fecha y hora haciendo doble clic en la hora que se muestra en la esquina inferior derecha de la pantalla de su equipo.
  2. Haga clic en la pestaña Hora de Internet.
  3. Active la casilla etiquetada Sincronizar automáticamente con un servidor horario de Internet.
  4. Escriba el nombre del servidor que seleccionó en el paso 3 de arriba en el cuadro a la derecha de Servidor.
  5. Haga clic en Actualizar ahora para asegurarse de que funciona correctamente.
  6. Haga clic en Aceptar para confirmar el cambio.

Factores que afectan a la precisión del protocolo NTP

  • La distancia entre el equipo y el servidor NTP
  • La carga en su red
  • Configuración de firewalls o servidores proxy

Pruebe diferentes servidores ITS si alguno de estos podría ser el problema.

Además, si el firewall o el servidor proxy de la red podrían ser el problema, compruebe el puerto UDP 123. El servicio Hora de Windows utiliza el puerto UDP 123 para el tráfico entrante y saliente; es posible que el tráfico en el puerto 123 esté bloqueado. Póngase en contacto con un administrador del sistema.

Id. de artículo:000008606

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