PROBLEMA

Las solicitudes tardan mucho en procesarse y agotar el tiempo de espera

Last Published: April 25, 2020

Descripción

Si tiene mapas muy complejos, puede ser necesario optimizar el rendimiento de ArcIMS actualizando el archivo AppServer.properties.

Causa

El archivo AppServer.properties contiene los valores predeterminados para el servidor de aplicaciones de ArcIMS. El valor predeterminado de las propiedades Timeout es 60 segundos y el valor predeterminado de las propiedades ExtendedTimeout es 300 segundos.

Se recomienda que estos valores predeterminados no se cambien; sin embargo, en sitios personalizados, pueden ser necesarios cambios en estas propiedades. Por ejemplo, es posible que deba aumentar la propiedad Timeout para que el servidor de aplicaciones no desista con la solicitud si el mapa no se transmite dentro del valor predeterminado de 60 segundos.

Solución o solución alternativa



Puede cambiar los valores de las propiedades Timeout y ExtendedTimeout en el archivo AppServer.properties.

En Windows:
El archivo AppServer.properties se encuentra en <ArcIMS Installation Directory>\AppServer.

En Solaris y Linux:
El archivo se encuentra en: $AIMSHOME/Middleware/Application_Server.

Timeout=60

El periodo de tiempo durante el cual el servidor de aplicaciones espera en un servidor espacial de ArcIMS para responder a una solicitud de cliente. El cronómetro de este periodo comienza tan pronto como se envía la solicitud al servidor espacial de ArcIMS desde el servidor de aplicaciones. Si el servidor espacial de ArcIMS no responde antes de que finalice este periodo, el servidor de aplicaciones desiste con la solicitud y devuelve un error de tiempo de espera al cliente.

Esta cifra se debe ajustar para sincronizarla con el tiempo de respuesta máximo para las solicitudes de servicio. El valor está en segundos.

ExtendedTimeout=300

El periodo de tiempo durante el cual el servidor de aplicaciones espera en un servidor espacial de ArcIMS para responder a una solicitud ADD/CHANGE SERVICE de un administrador. El cronómetro de este periodo comienza tan pronto como se envía al servidor espacial de ArcIMS la solicitud de agregar un servicio desde el servidor de aplicaciones. Si el servidor espacial de ArcIMS no responde antes de que finalice este periodo, el servidor de aplicaciones desiste con la solicitud ADD/CHANGE SERVICE y devuelve el error "error al agregar/cambiar servicio" al cliente de Administrador.

Esta cifra se debe ajustar para sincronizarla con el tiempo máximo que el servidor espacial de ArcIMS requiere para configurarse con las fuentes de datos y tareas relacionadas en la configuración de un nuevo servicio. El valor está en segundos.

Id. de artículo:000002168

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