Knowledge Base - Technical Articles


Technical Article   HowTo:  Import XY data tables to ArcMap and convert the data to a shapefile

Article ID: 27589
Software:  ArcGIS - ArcEditor 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3, 9.3.1, 10 ArcGIS - ArcInfo 8.0.1, 8.0.2, 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3, 9.3.1, 10 ArcGIS - ArcView 8.1, 8.1.2, 8.2, 8.3, 9.0, 9.1, 9.2, 9.3, 9.3.1, 10
Platforms: N/A

Summary

Tables containing X coordinates (Longitude) and Y coordinates (Latitude) can be brought into ArcMap and converted to a shapefile or geodatabase feature class.

Instructions provided outline one method to accomplish this task.

Procedure

The steps below give instructions for formatting XY data, in decimal degrees, using Microsoft Excel, and converting these data to a shapefile or geodatabase feature class in ArcMap.

There are several table formats that ArcMap can read, in order to bring point data into ArcMap as an event theme. These include DBase III, DBase IV, PRN, TXT, and CSV. Files in these formats can be created in Microsoft Excel.
 At version 9.1 and before, ArcMap cannot read an XLS file, the native format for MS Excel.


 At version 9.2 and later versions, XLS spreadsheets can be accessed directly in ArcMap through the Add Data dialog box.



  1. To ensure that ArcMap can read the data in the file correctly, use Excel to format the columns containing the Longitude (X) and Latitude (Y) values as NUMBER, with a minimum of 8 decimal places. -show me-

    This is the distribution of positive and negative values for Longitude (X) and Latitude (Y) coordinates worldwide.
    [O-Image] Decimal degree coordinates and signs
  2. Descriptions of the contents of each column are also required in the output file. Label columns ID, Longitude, Latitude, Description, etc. Extra sheets must be deleted because the DBF, PRN and CSV formats do not support multiple sheets.
     XLS spreadsheets support multiple sheets, and these may be used in ArcMap at version 9.2 and later versions.

  3. After formatting the file, select all the cells in populated rows and columns in the table and navigate to File > Print Area > Set Print Area.
  4. Navigate to File > Save As and select a supported format from the choices available in Excel. Click Yes when Excel warns that certain formatting is not supported in this file format.
  5. Exit Excel. Click No when Excel prompts to save the changes.
     If the changes are saved, Excel converts the file to an XLS Workbook that can only be used in ArcMap at version 9.2 and later versions.

  6. To add the data from the DBF, CSV, TXT or PRN file to ArcMap, navigate to Tools > Add XY Data and select the file. In Version 10.x, click File > Add Data > Add XY Data.
     To add an XLS spreadsheet to ArcMap, click the Add Data button, double-click the XLS spreadsheet, and select the sheet containing the XY coordinates.

    Be sure that ArcMap selects a column labeled Longitude or Long as X, and Latitude or Lat as Y.
  7. Click the Edit button to open the Spatial Reference Properties dialog box. Click the Select button to select a coordinate system for the data.

    As an example, GPS data is most often collected in units of decimal degrees or lat/long, which is a geographic coordinate system. Open this directory. Most frequently GPS data is collected on the WGS 1984 datum, so open the World folder, and select WGS_1984.prj.

    If the data has been collected on a different datum, click on the link titled "Geographic Coordinate Systems and Areas of Use" in the Related Information section below to find the appropriate datum.
  8. After defining the projection, click Add, Apply and OK on the Spatial Reference Properties dialog box, then click OK on the Add XY Data dialog box. The points will be drawn as an event theme in ArcMap.
  9. To convert the event theme to a shapefile or geodatabase feature class, right-click the file name, select Data > Export Data. The points can be exported to a geodatabase feature class or to a shapefile.
     The data can also be re-projected to the coordinate system of the ArcMap data frame during this process.

  10. If ArcMap warns that a "different geographic coordinate system than other data in the map", navigate to View > Data Frame Properties > Coordinate System tab, and click the Transformations button to verify that the correct datum transformation is being used for the area where the data is located. For a list of geographic (datum) transformations and their areas of use, click on the link "Select the correct geographic (datum) transformation when projecting between datums". Under the Related Information section of the article, download the list of transformations for the version of ArcGIS Desktop installed on the computer.

Related Information


Created: 9/1/2004
Last Modified: 3/7/2012

Article Rating: (3)
If you would like to post a comment, please login

Comments

By alex116 - 02/16/2012 1:06 PM

Other - See details below.

in ArcGIS 10 go to File>Add Data>Add XY Data

Rating:

By bodomalo - 02/13/2012 2:28 AM

I would like to see a new article that discusses the topic outlined below.

Same here, HOW can I do it in Arcgis 10? Your articles are somehow completely useless :-( Why telling people that this will not working with Arcgis 10 and do not give ANY hint what to do.

Rating:

By tseeepra - 06/15/2011 11:59 PM

The article needs to be updated.

So how can I do this in ArcGIS 10? The whole 'Tools' menu has been deleted.

Rating:

By Anonymous - 01/24/2007 9:01 AM

I followed the article’s instructions, but experienced another problem. I’ve provided details below.

The article is OK and the system works to import the data into ArcMap, but I am having difficulty at the "Display x / y data" stage. The basic objective is to import Excel data into an ArcMap project. This I do by saving the Excel spreadsheet as a Dbase4 table as per the instructions in the article above. In ArcMap 9.0, I import by the "ADD DATA" button; navigate to the folder and select the Dbase table. This imports OK and the table appears in the menu on the left-hand side of the screen. To d

By Anonymous - 09/21/2006 5:57 AM

Other - See details below.

The article is useful, but it's less troublesome to use ArcCatalog to create the shapefile: by right clicking on the dbf (or supported table) select "create feature class/from xy table" and you get right away your file. This avoids the intermediate step of creating an event theme (which I don't see the purpose of it in this case). Regards Eugenio Marcano