ERROR

Portal for ArcGIS does not have a valid license. For instructions on how to authorize the software, see the help topic Authorizing Portal for ArcGIS

Last Published: April 25, 2020

Error Message

After authorizing Portal for ArcGIS 10.5 with a license provisioned for a previous version, Portal for ArcGIS becomes inaccessible, returning the following error message:

Error:   
Portal for ArcGIS does not have a valid license. For instructions on how to authorize the software, see the help topic Authorizing Portal for ArcGIS.

Once authorization is complete, please open the Portal for ArcGIS website.

Cause

This is a known issue. Portal for ArcGIS versions 10.2 through 10.4.1 require a provisioned license that can be obtained from the My Esri website. For Portal for ArcGIS 10.5 and later, there is a license key requirement specific to the version of Portal for ArcGIS. However, the ArcGIS Software Authorization Wizard accepts license files provisioned for either portal versions. Therefore, Portal for ArcGIS rejects the invalid license information and the above error is returned.

Solution or Workaround

The instructions provided describe a workaround for this issue:

  1. Stop Portal for ArcGIS.
  2. Open Program Files (x86)\Esri\License10.5\sysgen\keycodes (or C:\Program Files\ESRI\License10.5\sysgen\keycodes) with a text editor.
  3. Remove the invalid license details for any incorrect software version listed.
  4. Restart the software.

OR

  1. Stop Portal for ArcGIS.
  2. Navigate to Program Files (x86)\Esri\License10.5\sysgen\ (or C:\Program Files\ESRI\License10.5\sysgen).
  3. Delete or rename the Keycodes file.
  4. Re-license Portal for ArcGIS with the correct license.

Article ID:000015298

Software:
  • ArcGIS Server
  • Portal for ArcGIS

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