English

How To: Create contour lines from Lidar data

Summary

Lidar (light detection and ranging) is an optical remote-sensing technique that uses laser light to sample the earth’s surface and produce highly accurate x,y,z measurements. Contour lines can be created from the lidar data (.las) to give information on elevation of the earth’s surface. Each contour line feature is created by connecting contiguous points with equal height values from the lidar data.

The instructions provided describe how to create contour lines from lidar data.

Procedure

Create an LAS dataset before creating contour lines from the lidar data. For instructions on how to create an LAS dataset, refer to the following web help document, Managing LAS datasets: Creating a LAS dataset.

Note:
Spatial reference must be defined for each LAS file. ArcGIS reads and uses this spatial reference information. Defining the spatial reference at the LAS dataset level alone is not enough. LAS data might not be displayed due to different projections between the map and the LAS data, or the spatial reference for the LAS files is not defined properly.

Contour lines can be created from the lidar data using one of the following options
Note:
The first option requires the 3D Analyst extension, and the second option requires either the 3D Analyst extension or the Spatial Analyst extension.

Create contour lines directly from the LAS dataset

  1. Add the LAS dataset into ArcMap.
  2. Open the Surface Contour tool. Navigate to 3D Analyst Tools > Triangulated Surface > Surface Contour.
    1. Browse the LAS dataset as the Input Surface.
    2. Set a name and location for the Output Feature Class.
    3. Set the Contour Interval parameter with the desired interval between the contour lines.
User-added image
  1. Click OK. The contour lines with the specified interval are created on the map.
User-added image

Contours created from full-resolution Lidar tend to be jagged with many twists and turns and isolated closed rings due to high frequency noise. For more information about noise from Lidar and how to get less jagged contours, refer to the following documentation: Minimizing noise from lidar for contouring and slope analysis.

Create contour lines from a raster that is created from the LAS dataset

  1. Add the LAS dataset into ArcMap.
  2. Open the LAS Dataset to Raster tool. Navigate to Conversion Tools > To Raster > LAS Dataset to Raster.
    1. Browse the LAS dataset as the Input LAS Dataset.
    2. Set a name for the Output Raster.
    3. Select Binning for the Interpolation Type.
User-added image
Note:
Binning interpolation determines the value of a pixel by examining the points that fall within the pixel to determine the final value. Triangulation interpolation is recommended for low-density Lidar data where it uses Delaunay triangulation to create a surface from a network of triangular facets defined by nodes and edges covering the surface before rasterizing it.
  1. Click OK. A raster is displayed in the map.
  1. Open the Contour tool. Navigate to 3D Analyst Tools > Raster Surface > Contour, or if 3D Analyst extension is not available but Spatial Analyst extension is available, navigate to Spatial Analyst > Surface > Contour.
    1. Browse the raster dataset as the Input raster.
    2. Set a name and location for the Output polyline features.
    3. Set the Contour interval parameter with the desired interval between the contour lines.
    4. Click OK. The contour lines with the specified interval are displayed in the map.
User-added image
Note:
Every Lidar point can have a classification assigned to it, defining the type of object that has reflected the laser pulse including bare earth or ground, the top of a forest canopy, or water. For more information of the Lidar data classification, refer to the following documentation: Lidar point classification. For steps to filter the Lidar data, refer to the following documentation, LAS dataset layer properties in ArcMap: Filter tab.

Related Information