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Problem: Unable to access a federated Server Manager using the Google Chrome browser

Description

When ArcGIS Server and Portal for ArcGIS are installed on the same machine and are federated, attempting to access Server Manager through port 6443 using a Google Chrome browser fails to complete. The login appears successful but Server Manager hangs with the 'Please wait...' dialog window.

Cause

This issue is caused by Google Chrome not trusting the default self-signed SSL certificate installed on ArcGIS Server over port 6443. During the initial access of Server Manager over 6443, a warning is prompted that states 'Your connection is not private' and to continue, the user must select the option to proceed. This action causes Chrome to create a temporary exception so the site can continue to be accessed with any warnings.

Since ArcGIS Server and Portal for ArcGIS are federated, the user is redirected to the Portal sign-in page. This URL has the same host name but is through the Portal web adaptor which uses a SSL certificate that Chrome already trusts. Because the host name is the same and the SSL certificate is trusted, Chrome removes the previously created exception.

When the Portal sign-in is successful, the user is redirected back to the Server Manager over 6443. Because the exception was dropped, several of the subsequent Manager requests fail and the 'Please wait...' dialog window displays and never changes.

Solution or Workaround

The recommended solution for this issue, which follows the security best practices outlined in the Help documentation (see Related Information below), is to generate or import a CA-signed SSL certificate and configure ArcGIS Server to use this certificate instead of the self-signed certificate configured by default. This allows Google Chrome to trust any SSL certificates being used.

Related Information