English

Error: Unable to create an XML workspace when the X-Ray for ArcCatalog add-in is installed

Error Message

In ArcCatalog, creating an XML workspace with the X-Ray for ArcCatalog add-in installed prompts the following error message,

Error:   
"Could not load file or assembly 'office, Version=15.0.0.0, Culture=<neutral>, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified."

Error message which prompts when running X-Ray for ArcGIS

Cause

X-Ray for ArcCatalog requires Microsoft Excel for full functionality.  The following are possible causes for this error:

  • This error can be returned when no installation of Microsoft Excel is found.
  • A version of Microsoft Excel is installed that is not compatible with the version of X-Ray for ArcCatalog.

Solution or Workaround

Install the corresponding version of Microsoft Excel and reinstall the X-Ray for ArcCatalog add-in.

  1. Install the appropriate version of Microsoft Excel that coincides with the version of X-Ray for ArcCatalog.
  • For ArcGIS for Desktop 10.1, install Microsoft Excel 2007 or 2010 and the corresponding X-Ray for ArcCatalog: X-Ray for ArcCatalog (ArcGIS 10.1).
  • For ArcGIS for Desktop 10.2 through 10.4.x, install Microsoft Excel 2013 and the corresponding X-Ray for ArcCatalog: X-Ray for ArcCatalog.
Note:
Add-ins are not backward compatible. For example, add-ins targeting version 10.1 do not work with version 10.0, but work with version 10.2.
  1. Reinstall X-Ray for ArcCatalog. The following ArcGIS for Desktop document describes this in detail: Sharing and installing add-ins.
Note:
Another component to consider installing when dealing with Microsoft Office components is the 2007 Office System Driver, which resolves a number of interoperability issues between Excel and ArcGIS. Find the download here, 2007 Office System Driver: Data Connectivity Components.

Related Information