PROBLEM

Unable to view reports in Esri Business Analyst Desktop when SSL is enabled in an ArcGIS Online organization

Last Published: April 25, 2020

Description

Reports do not display in Esri Business Analyst Desktop.

Cause

Esri Business Analyst Desktop reports are not displayed when an organization enables Secure Sockets Layer (SSL), because there is a higher security protocol on how services communicate. Therefore a secure connection to ArcGIS Online is required to enable programs such as Esri Business Analyst Desktop, ArcGIS for Desktop, and Business Analyst Web Apps to communicate with each other.

Solution or Workaround

Connect to a secure ArcGIS Online Organization by following the steps:
  1. Navigate to Start > All Programs > ArcGIS, and click ArcGIS Administrator.
  2. Select the machine name to specify the machine to be edited, and click Advanced.
    Image displays the options to select in ArcGIS Administrator.
  3. In the Advanced Configuration dialog box, click Manage Portal Connections.
  4. In the Manage Portal for ArcGIS Connections dialog box, click Add.
  5. In the Add Portal for ArcGIS dialog box, type https://www.arcgis.com, and click OK.
  6. Click the newly added URL, and click Connect.
    Image displays the steps to create a connection with the new URL.
  7. Click Save to apply the new settings.
  8. Open Business Analyst Desktop and login with ArcGIS Online credential to confirm the reports are now available.

Article ID:000013857

Software:
  • ArcGIS Online
  • More Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic