English

FAQ: Does the .NET version affect the usage of ArcGIS for Desktop and development in ArcObjects?

Question

Does the .NET version affect the usage of ArcGIS for Desktop and development in ArcObjects?

Answer

Yes, the .NET version does affect the installation of ArcGIS for Desktop and ArcObjects. The .NET version must be compatible with the version of ArcGIS for Desktop and ArcObjects. For example, installation of ArcGIS Desktop and ArcObjects 10.0 requires, at a minimum, the .NET Framework 3.5 Service Pack 1. This is also true for ArcGIS Desktop 10.1, 10.2.x and 10.3.x.

ArcGIS for Desktop 10.4.x and 10.5.x require the .NET Framework version 4.5 or higher. Please note that this version is also able to support an older Desktop installation, such as ArcGIS for Desktop 10.0.

For more information regarding the system requirements for various 10.x releases of ArcGIS for Desktop, ArcObjects, and Engine SDKs, refer to the following Web Help documents.

Related Information