English

How To: Set up Visio 2002 Professional for CASE Tools

Summary

Visio 2002 introduced the XML Metadata Interchange (XMI) format for transferring UML diagrams to an Esri geodatabase. The instructions provided describe how to install the XMI Exporter into Visio 2002 and use it to generate the XMI file for the ArcCatalog Schema Wizard.

Procedure

 

  1. Download and install Visio 2002 Professional Service Release 1.
  2. Download the UML to XMI Export Functionality install file, XMIExport.exe, and save it to disk.
  3. Double-click the XMIExport.exe file. The file extracts to a directory.
  4. From the extraction directory, copy XMIExport.dll to the Visio 2002 installation directory <Visio Installation Path>\DLL.
  5. Copy the file ESRI XMI Export.vsl located under the ArcGIS installation directory ...\CaseTools\Utilities to the Visio 2002 installation directory ...\Microsoft Office\Visio10\1033\Solutions\Visio Extras
     
    Warning:
    Do not follow the Microsoft documentation that requires the VisioUmlAddon.vsl file to be created. The ESRI XMI Export.vsl supersedes it. 
  6. Start Visio and open the *.vsd. If the Visio diagram is from an older version, a shape migration process is necessary. When prompted, make a backup of the *.vsd.
  7. Export the model to XMI by going to Tools > Macros > Visio Extras > XMI Export. Choose Save As, and give the output file a new name. Successful export notification should follow.
  8. Copy the uml.dtd file from the ArcGIS installation directory...\CaseTools\Utilities\ to the directory where the XMI file is saved.
     
    Note:
    The uml.dtd file is used to define and validate the XMI file created by Visio. This file should always accompany the XMI file.
  9. Open the Semantics Checker in Tools > Macros > ESRI > Semantics Checker. Select Models Stored in XMI, browse to the XMI file and click Check.
  10. Any reported errors must be fixed before continuing. After fixing the errors the file must be exported to a new XMI file and checked with the Semantics Checker (Steps 7 - 9).
  11. After the XMI file has been checked, it can be used in the ArcCatalog Schema Wizard to generate a personal or enterprise geodatabase.

Related Information