English

Problem: Inserted or pasted Word and Excel objects, documents, and tables do not print or export correctly

Description

Inserting and/or copying and pasting objects and documents made from other Windows applications, such as Microsoft Word or Excel, do not print or export correctly, are of low quality, and/or may be missing elements.

Cause

These are known limitations.

Many of these issues have been resolved in ArcGIS 9.x; however, testing efforts show that using Insert > Object is a better method than simply copying and pasting from a Windows application into ArcMap.

Solution or Workaround

The following are possible workarounds for problems inserting or pasting Windows application objects and documents into ArcGIS.
 

  • Inserting just text from MS Word or another text editor:

    If the Word document or Excel table contains just plain or formatted text, copy and paste the text into a new text box in ArcMap.
    1. On ArcMap's Drawing toolbar, select the New Text tool and click the map layout.
    2. Click outside the page to unselect it, and double-click the new text box just added to the map.
    3. Paste the copied text from the Word document into this box and apply any formatting needed.

    [O-Image] [O-image] Copy and paste text into new text tool
 
  • Inserting formatted text and other Word or Excel graphics and/or tables:

    If both inserting the object directly or copying and pasting the object produces bad or incorrect output, create a screenshot of the object or document and insert it as a picture.
    1. Open the application in which the table was originally created, such as Word or Excel, and select Print Preview.
    2. Zoom to the preview so that it is at 100%. Take a screenshot by pressing the Print Screen button on the keyboard.
    3. Select Start > Programs > Accessories > Paint to start Paint.
    4. Select Edit > Paste to paste the screenshot.
    5. It is best to crop the screenshot down to just the graphic and text elements you want to insert into the map. To do this, click on the Select tool (dotted line box) and draw a box around the elements to be inserted into the map.
    6. Select Edit > Copy.
    7. Select File > New. Click No when the dialog box Save changes to untitled? appears.
    8. To ensure that the newly cropped image is as small as it can be, resize the page footprint in Paint. To do this, left-click on the bottom right corner of the white page in Paint and drag it close to the top left corner.
    9. Select Edit > Paste.
    10. Select File > Save As and select 24-bit Bitmap (BMP) as the type.
    11. In ArcMap and while in layout view, select Insert > Picture and browse to the BMP just created. Place it as desired on the map layout and resize the image as necessary.
    12. Right-click the picture and select Properties.
    13. On the Picture tab, check Save Picture as Part of Document.

    [O-Image] Inserting stuff as screenshots
 
  • If the map layout is larger than 8.5" x 11"/A4, try the workaround procedure in the Related Information section below.

Related Information