English

Bug: ArcGIS Software Authorization Wizard and 'Check for Updates' shortcuts do not work on SUSE Linux Enterprise Server 11 SP1

Description

The ArcGIS Software Authorization Wizard and Patch Notification tool cannot be run in GUI mode on SUSE Linux Enterprise Server 11 SP1 (SLES).

When trying to run the ArcGIS Software Authorization Wizard or 'Check for Updates' from the shortcut menu on SLES 11 SP1, the applications never appear. Running these tools in GUI mode from the ArcGIS installation directory under the tools folder also fails.

Note:
This problem is only observed on SUSE Linux Enterprise Server 11 SP1.

Cause

The ArcGIS Software Authorization Wizard and Patch Notification tool use a local X11 library that is incompatible with the X11 authorization mechanism on SUSE Linux Enterprise Server 11 SP1 only.

Workaround

There are simple workarounds for this issue:

  1. Run the ArcGIS Software Authorization Wizard and Patch Notification tool in console mode.

    a. For the ArcGIS Software Authorization Wizard, browse to the tools folder under the ArcGIS installation directory and run:
    Code:
    % <ArcGIS_InstallDir>/tools/authorizeSoftware -f licenseFile.prvc

    b. For the Patch Notification tool, run the tool with a '-c' option:
    Code:
    % <ArcGIS_InstallDir>/tools/patchnotification/patchnotification -c

  2. a. Once logged into the GNOME desktop, open a terminal and run xhost + as the ArcGIS installation account:
    Code:
    % xhost +

    b. Run the tools from the shortcuts or in GUI mode as normal.