ERROR

Error 1327. Invalid Drive

Last Published: October 12, 2021

Error Message

When installing ArcGIS Desktop, the following error message is displayed:

"Error 1327. Invalid Drive X:\"

The drive letter may be different and usually does not exist, or is not a valid or currently connected network drive.

Note:
This may occur when installing any Esri product.

Cause

The registry contains references to a hard drive or network drive that is no longer connected.

Solution or Workaround

Warning:
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary. 
Esri cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.
  1. Navigate to Start > Run, type regedit and click OK.
  2. In the Windows Registry Editor, expand the following node:
 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
  1. In the right pane, look for any values in the Data field that contain a drive that is not correct or currently connected. If found, right-click the entry and select Modify.
  2. Type c:\my documents in the Value data box, and click OK.
  3. Navigate to each of the registry folders listed below and repeat Step 3 for each of the following registry keys that list a drive that is not connected. Enter the values indicated for each key.
List of registry folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data Value for all keys (except 'Default') starts with:

  • %USERPROFILE%
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

Data Value for all keys (except 'Default') should start with one of the following:

  • C: %SystemRoot%
  • %ProgramFiles%
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

Data Value for all keys (except 'Default') should start with the following:

  • C:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data Value for all keys (except 'Default') should start with one of the following:

  • %PUBLIC%
  • %ProgramData%
  1. Close the Registry Editor and install ArcGIS Desktop.

Article ID:000012682

Software:
  • ArcMap 10 x
  • ArcMap 9 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic