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Problem: After running an Full Index in Portal for ArcGIS Admin API, the Index Counts for Store and Index do not match

Description

After running a Full Index in the Portal for ArcGIS Admin API, the Index Counts for Store and Index do not match, implying that indexing is not complete.

[O-Image]

Cause

The indexing in the Portal for ArcGIS installation has become corrupt.

Solution or Workaround

  1. Stop the Portal Service in Windows Services.
  2. Rename the 'index' folder at ...\arcgisportal, for example, 'index_old'.

    Warning:
    Do not delete this folder as it can serve as a backup.

  3. Unzip the file 'empty_index.zip' at the following location:

    ...\Program Files\ArcGIS\Portal\framework\template 

    Move the unzipped 'index' folder to ...\arcgisportal.
  4. Start the Portal Service in Windows Services.
  5. Rebuild full indexes with the Portal Admin API:

    https://<machine>.<domain>.com:7443/arcgis/portaladmin/system/indexer