English

Error: db_get_dbms_release:: Invalid Release (12.1.0.2.0) cannot determine DBMS release using SDO_ADMIN.sdo_version function

Error Message

When running ArcSDE 10.2 command line tools on Oracle 12.1.0.2.0, the following error is returned:
 

Error:   
"Error: Underlying DBMS error (-51)
Error: Could not create a connection
Extended DBMS error code: 0
Unknown error
No extended error"
In addition, the following error message is observed in the sdedc_oracle.log file:
 
Error:   
"db_get_dbms_release:: Invalid Release (12.1.0.2.0) Cannot determine DBMS release using SDO_ADMIN.sdo_version function.
Can’t open instance:sde:oracle11g.
Spatial Engine Connection Failed (-51). Cannot Get Access to Instance sde:oracle11g."

Cause

The error is encountered because Oracle version 12.1.0.2.0 is not supported in ArcSDE version 10.2.

Solution or Workaround

Install ArcSDE version 10.2.1 or 10.2.2 command line tools for successful execution as the support for Oracle 12C begins at ArcGIS version 10.2.1.