English

Bug: Apps created from a configurable app template through My Content in Portal for ArcGIS cause an error when attempting to open the app

Description

Attempting to open an app created from a configurable app template via 'My Content > Create App > Using a Template' may result in a 404 error.

Cause

This is a known issue.

The ArcGIS Web Adaptor name is missing from the app URL.

Workaround

Option #1

Use an alternative workflow: open the web map in the map viewer and click Share. Select any template in the gallery to configure an app. The app created from this workflow is not impacted by the URL issue discussed in this article. For more information, see the help topic Make your first app.

Option #2

A broken app can be fixed by inserting the Web Adaptor name missing from the URL. The instructions provided describe how to fix the broken app URL.

  1. From the My Contents page, open the Item Details page for the broken app.
  2. Under Properties, note the URL that is displayed. The portion of the URL with the web adaptor name may be missing, similar to the example below:

    https://webadaptorhost.domain.com/apps/Viewer/index.html?appid=84ad30cce2f24d5abd1c5b212239dbc0 


    The URL must include the web adaptor name, as follows:

    https://webadaptorhost.domain.com/<webadaptorname>/apps/Viewer/index.html?appid=84ad30cce2f24d5abd1c5b212239dbc0

  3. Click Edit, and modify the URL property to include the web adaptor name.
  4. Click Save.
  5. To continue configuring the app, click Configure App. To view the app, click Open > View Application.