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Problem: The ArcGIS GeoEvent Extension for Server fails to launch on servers running McAfee Enterprise Suite Anti-Virus

Description

One component of the McAfee Enterprise Suite, the On-Access Scanner, has been shown to prevent the proper installation and startup of the ArcGIS GeoEvent Extension for Server. This Anti-Virus processor is intended to actively scan any files in use, but when working with highly compressed archive files such as the JAR files utilized by the GeoEvent Extension, multiple timeout failures can occur while waiting for the scans to complete.

Cause

This has been previously documented by McAfee in the following Knowledge Base Article but may also effect other anti-virus products performing similar scans.

McAfee Knowledge Center: KB55869 Explanation of why scan time-outs occur

"File extensions such as .jar, .chm, .cab, and .zip are all archive files that typically use a very high compression. To scan these archives, each file must be extracted from the archive. This can use a large amount of memory depending on the type of data in the archive and how well it compresses...Access to the file is denied until the scan is complete (this might be minutes or even hours...)". "If the scan of a particular file takes longer than allowed by the time-out value, the scan is stopped."

Solution or Workaround

For the GeoEvent Extension to function, this component must be either disabled or granted exclusions for all of its necessary files in the following default installation paths:

C:\Program Files\ArcGIS\Server
C:\ProgramData\Esri\GeoEvent
C:\Users\arcgis\AppData

McAfee has a second KB discussing the alternate ways around this behavior including disabling the archive scans, adding the explicit files to a whitelist, and excluding all similar files from scanning.

McAfee Knowledge Center: KB58727 Slow performance with Java-based applications