English

How To: Display an AutoCAD drawing file in ArcMap

Summary

This article provides instructions for adding AutoCAD drawing files to ArcMap, identifying problems that may prevent the data from drawing, and tips on correcting these issues in AutoCAD.

Procedure

The following steps are useful when applied to an AutoCAD drawing file in the native application, before adding the file to ArcMap.

Note:
ArcGIS Desktop does not support features created in AutoCAD Civil 3D or AutoCAD Land Desktop using Object data. If these files are opened and re-saved in AutoCAD, some of the Object data may be converted to entities that draw in ArcMap or convert to a geodatabase. If possible though, use of Object data in AutoDesk files which are brought into ArcGIS Desktop should be avoided.

  1. Create a copy of an AutoCAD file.

    a. Save a copy for the drawing file in AutoCAD with a name that does not contain spaces or hyphens. If the name contains spaces or hyphens, substitute both characters with underscores.
    b. Navigate to Insert > External References, and detach any external references attached to the file. Save the AutoCAD drawing file again.
    c. Navigate to Format > Units. Take note of the units used to create the file.
    d. Navigate to Layer Manager, and turn on, unfreeze, or unlock any layers which are turned off, frozen, or locked. This enables the data to draw in ArcMap.
    e. Save the AutoCAD drawing file.
  2. Add the AutoCAD drawing file to ArcMap to modify features.

    a. Open a blank map in ArcMap.
    [O-Image]

    b. Navigate to the Tools toolbar and select the Add Data drop-down.
    [O-Image]

    c. Browse to the location where the new copy of the AutoCAD drawing file is saved, and double-click the .dwg file.
    [O-Image]

    d. Individually add the feature types from the file. This helps isolate the feature type(s) that are causing issues.
    [O-Image]
    Note:
    Adding feature types individually to ArcMap allows access to individual layer properties. Adding the group layer blocks access to this information.


    Warning:
    If any issues arise with the data displayed in the ArcMap session, the AutoCAD drawing file must be amended. Refer to steps 3-5.

  3. In ArcMap, remove the problematic layers from the .dwg files. Right-click a specific layer, and select Remove.
    [O-Image] [O]

  4. In AutoCAD, navigate to Edit > Select all, and apply the Explode command to explode the blocks.

    Note:
    The Explode command may cause inaccessible features to be available. It is recommended to apply the Explode command at least once, although the command may need to be applied several more times since blocks may be embedded up to nine levels deep.

  5. Save the drawing file in AutoCAD, and repeat Step 2.

Related Information