English

Error: Sorry, an error has occurred. The application cannot be installed due to a certificate problem

Error Message

When upgrading an older version of Esri Maps for SAP BusinessObjects, the following error message may be returned.

“Sorry, an error has occurred.

The application cannot be installed due to a certificate problem. The certificate does not match the installed application certificate, does not support application updates, or is invalid. Please contact the application author.”
[O-Image] AIR certificate invalid

Cause

This error occurs when the Adobe AIR (Adobe Integrated Runtime) certificate used to sign the installed Esri Maps Designer application is different from the certificate used to sign the newer version of the Esri Maps Designer application.

Solution or Workaround

Follow the solution provided below.

  1. Open the Windows Control Panel and navigate to Programs and Features.
  2. From the list of installed programs, double-click 'Esri Maps Designer for SAP Dashboards' and uninstall the application.
  3. Install the new version of Esri Maps for SAP BusinessObjects, as described in the Installation Guide.

Related Information