English

Bug: The ArcGIS Web Adaptor unregisters or loses its configuration and resets to the default or blank configuration

Description

The ArcGIS Web Adaptor unregisters or loses its configuration, and resets to the default or blank configuration in the webadaptor.config file.

Cause

The ArcGIS Web Adaptor sends periodic messages to verify connectivity to the ArcGIS Server. If there is a disconnect or loss of communication during these periodic messages, the web adaptor loses its configuration. This happens in most cases where communication may be across the network, but also less frequently when the Web Adaptor is installed on the same machine as the ArcGIS Server.

Workaround

 

Note:
This issue can be resolved by maintaining a copy of the webadaptor.config file.
 
  1. Install and configure the web adaptor. If necessary, refer to the links below for assistance with installation or setup of the web adaptor.

    Installing the ArcGIS Web Adaptor

    Configuring the ArcGIS Web Adaptor

    Once a copy of the webadaptor.config file is saved, it is no longer necessary to reinstall and reconfigure the web adaptor if the issue reoccurs.
  2. On the Web Adaptor machine, navigate to the following default location.
     
    C:\inetpub\wwwroot\arcgis\webadaptor.config
  3. Right-click the webadaptor.config file, and select Copy. Navigate to a secure location of choice and paste the webadaptor.config file to this location.

    A new folder can also be created. Name the folder and place the file in the following location.
     
    C:\inetpub\wwwroot\arcgis\ 
  4. If or when the issue occurs and the webadaptor.config loses its contents, restore the file from the copy created in Step 3. Navigate to the saved copy, right-click, and select Copy. Navigate to and paste over / replace the unregistered file.
     
    C:\inetpub\wwwroot\arcgis\webadaptor.config