English

Error: The app domain with specified version id (%d) was unloaded due to memory pressure and could not be found

Error Message

When working with data stored in a SQL Server database, ArcGIS client applications may encounter errors.

"[Microsoft][SQL Server Native Client 11.0][SQL Server]There are no rows in the current fetch buffer."

The above error has been reported when displaying or editing Microsoft geometry and geography spatial types in ArcGIS. ArcGIS clients may report that an operation could not be completed because an objects schema has changed.

When this error is reported by ArcGIS, it is important to review the SQL Server error logs. Look for the following message to determine if the root cause is application domain unloads due to memory pressure.

"The app domain with specified version id (%d) was unloaded due to memory pressure and could not be found."


Note:
By default, the error log is found in the following folder location:

C:\Program Files\Microsoft SQL Server\MSSQL##.MSSQLSERVER\MSSQL\Log


Cause

Microsoft SQL Server spatial types are heavily dependent on the Common Language Runtime (CLR). When the application domain hosting the CLR data is unloaded, this is treated as a schema change to the database engine, and may result in errors while displaying and editing feature classes stored using either the geometry or geography types. There are many reasons why the application domain may be unloaded, including memory pressure.

As the error indicates, this is a memory issue within SQL Server that forces the CLR application domain hosting the spatial type to unload.

Solution or Workaround

Microsoft states that enabling CLR allows the caching of the spatial assemblies, but notes that memory pressure may still unload the application domain or assembly, and in those cases, the root cause of the memory pressure must be investigated.

If any of the mentioned errors are encountered while using ArcGIS or in the SQL Server error logs, it is recommended to contact Microsoft Support to further investigate the root cause of the error.

For additional details when working with Microsoft Support, please refer to Incident #114080611682006 and Defect #3374271.