PROBLEM

Unable to delete a lock in a copied file geodatabase

Last Published: April 25, 2020

Description

When working with the contents of a file geodatabase (for instance, adding a new feature class), a read lock is created. A read lock means other users are able to read the file, but are unable to edit the file. Only the first person who gets the read lock is allowed to edit the file. Together with the read lock, a timestamp file is automatically generated.

When a user creates a file geodatabase, a read lock is created. When the file geodatabase is copied, the read lock is copied along with it. When the user attempts to delete the copied lock, the deletion of the lock is not processed.

Cause

The read lock cannot be deleted due to the following reasons:

• The user may not have permission to delete the lock
• The file geodatabase is in still use by another application, such as ArcMap or ArcCatalog

Solution or Workaround


Warning:
When working with the contents of a file geodatabase, only delete the lock file. Do not delete the timestamp. Timestamp files must never be altered or deleted, as this corrupts the make-up of the geodatabase.

  1. If the geodatabase is stored on a network drive, determine by which user or machine the lock is held. The machine name that holds the lock is contained in the name of the lock.
  2. From the machine in Step 1, close ArcMap or ArcCatalog.
  3. Refresh the geodatabase folder in Windows Explorer. Check if the lock has been removed.
  4. If refreshing the geodatabase does not remove the lock:

    i. Launch Windows Task Manager.
    ii. Click the Process tab, and end the ArcMap or ArcCatalog process.
  5. Check if the lock has been removed.

    Warning:
    To perform the steps above, ensure nobody is accessing the data. Their work may not be saved as a result.

Article ID:000011983

Software:
  • ArcMap

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic