English

Problem: Unable to run the custom widget in ArcGIS Viewer for Flex

Description

In some situations, the user is unable to run a custom widget in the ArcGIS Viewer for Flex application.

Cause

The issue mainly occurs when the widget is run on a version of ArcGIS Viewer for Flex that is different than the version it was compiled on.

Solution or Workaround

When compiling a Viewer for Flex widget, the Flex SDK and the ArcGIS Viewer for Flex application must be the same version.

This becomes especially important when a widget is written expecting a specific query or syntax, and one of the references is changed between release dates.

It is highly recommended that users deploy widgets on the same version of ArcGIS Viewer for Flex application.

Note:
For example, if the widget is compiled on ArcGIS Viewer 3.5 for Flex, it may be possible to deploy the widget to ArcGIS Viewer 3.1 for Flex - but this is not supported by Esri.

Related Information