English

Problem: Esri Maps for IBM Cognos 5.0.1 does not work after installing IBM Cognos 10.2.1 Fix Packs

Description

After installing IBM Cognos 10.2.1 Fix Packs, Esri Maps for IBM Cognos 5.0.1 does not work.

When opening Esri Maps for IBM Cognos Properties, the following error messages may be returned:

"Publish failed. Version conflicts"
[O-Image]
"Publish failed. IBM Cognos returned an error during publish"
[O-Image]

Cause

The report schema version used in Esri Maps for IBM Cognos 5.0.1 for IBM Cognos 10.2.1 is not compatible with the report schema version that is used in IBM Cognos 10.2.1 Fix Packs.

Solution or Workaround

To update the report schema version to work with the Fix Packs for IBM Cognos 10.2.1, perform the following steps on each Esri Maps for IBM Cognos Server installation:

  1. Ensure that Esri Maps for IBM Cognos 5.0.1 has been installed using the option to install for IBM Cognos 10.2.1.
  2. Make a backup of the defaultSpec.xml file in this location:

    <Esri Maps for IBM Cognos install folder>\webapps\em4c

  3. Extract the attached zip file, which contains a file called defaultSpec.xml.
    defaultSpec.zip
  4. Copy and paste the extracted defaultSpec.xml to the following location, replacing the original file:

    <Esri Maps for IBM Cognos install folder>\webapps\em4c

  5. Clear the browser cache.