English

Bug: Error during reconcile: "The version could not be reconciled. Invalid network element id."

Description

When reconcling a version that has edits to a geometric network along with one of the following ArcGIS releases, the reconcile may fail with the error "Invalid network element id":

• ArcGIS 10.1 SP1
• ArcGIS 9.3.1 SP2 + Geodatabase Patch

In all reported cases of this bug the error message has been:

"The version could not be reconciled."
"Invalid network element id."

No additional errors were recorded. If an error message is displayed that contains the phrase "Invalid network element id" along with other errors, it may be due to a different issue.

Cause

The failure is due to NIM087777.

Workaround

This issue has been addressed in the ArcGIS 10.2 release and is available as a public patch for ArcGIS 9.3.1 SP2 + Geodatabase Patch.

If ArcGIS 10.2 is not available, the workaround for this issue is removing the service pack or patch that is causing the error and reconciling the version that is raising the error.

If using ArcGIS 10.1 SP1, use ArcGIS 10.1 to reconcile the version.

    Related Information