English

Error: ERROR 000100: The dataset %s cannot be versioned. Failed to execute

Error Message

An error occurs when trying to upgrade an existing parcel fabric after upgrading the geodatabase to 10.1. The same error is encountered when using either the Upgrade Dataset tool or the Update Parcel Fabric tool:

"ERROR 000100: The dataset %s cannot be versioned. Failed to execute (UpgradeParcelFabric)."

"ERROR 000100: The dataset %s cannot be versioned. Failed to execute (UpgradeDataset)."

Cause

The parcel fabric must be unregistered as versioned to be upgraded.

Solution or Workaround

To upgrade the parcel fabric to the current release, the feature dataset that contains the parcel fabric must be unregistered as versioned. Before unregistering the feature dataset, it is important to reconcile/post all user versions to the default version and achieve a full compress.


Note:
To upgrade the parcel fabric the geodatabase must first be upgraded to the current version/patch level of the ArcGIS client.


Note:
The Upgrade Parcel Fabric tool was deprecated at version 10.1. This functionality has been replaced by the Upgrade Dataset tool that upgrades the schema of a mosaic dataset, network dataset or parcel fabric to the current ArcGIS release.

Related Information