English

Error: Upgrading a geodatabase on Oracle to version 10 fails with a "User does not have required privileges" error and indicates "Success"

Error Message

In certain situations, upgrading an enterprise geodatabase for Oracle to version 10 fails with the following error message:
"Error: User does not have required privileges to upgrade. [Success]"

The error is raised even though all the required privileges have been granted to the geodatabase admin user and the public role.

Cause

The error is unique to particular conditions within the geodatabase schema in Oracle and cannot be identified without working with Esri Customer Support.

Solution or Workaround

If this error message is encountered when trying to upgrade to Enterprise geodatabase 10.0 on Oracle, please contact Esri Technical Support.

    Related Information