English

Error: This version of the Geodatabase is compatible with the dataset and cannot open it

Error Message

Using 10.0 SP2 or a later 10.0 service pack, the following error is returned when attempting to open a dataset in a 10.x geodatabase:

"This version of the Geodatabase is compatible with the dataset and cannot open it.[dataset name: <name of dataset>]"

Cause

The dataset contains functionality specific to Version 10.1. At ArcGIS 10.1, several datasets have been updated to provide new functionality. They are as follows:

• Support for Python scripting is available with annotation and dimension feature classes.
• Tables and feature classes now support editor tracking.
• Network datasets support live traffic data, soft restrictions, preferred truck routes, and Python script evaluators.
• Workflows and tools for creating and editing mosaic datasets have been improved, including improved generation of seamlines and footprints, support for more raster types, additional properties, and tools to analyze the mosaic dataset for known errors or limitations.

Solution or Workaround

Use ArcGIS 10.1 to open the dataset.