PROBLEM

Caching process creates blank/white tiles when using Mosaic dataset

Last Published: April 25, 2020

Description

The caching process sometimes creates blank and/or white tiles when using Mosaic datasets. When this happens no error is reported in the server log because the tiles are actually created in the cache folder but are white.

Cause

The map caching process draws the map data for the extent the cache tiles need. In that process, sometimes raster datasets fail to display all the images in that extent and results in creating white tiles.

Solution or Workaround

There is a parameter called 'Maximum Number of Rasters per Mosaic' available in the Mosaic Dataset Properties dialog box whose default value is 20. This prevents the server from mosaicking an unreasonably large number of rasters if, for example, the client zooms in to an overview scale in a non-optimized image service dataset that has no overview tiles generated.

Increase the 'Maximum Number of Rasters per Mosaic' value to higher number so that all the images are visible for the required extent in the caching process.

  1. To change the mosaic dataset properties, first stop all the map services that are using it.
  2. Right-click on the mosaic dataset and click Properties to open the Mosaic Dataset Properties dialog box.
  3. Change the Maximum Number of Rasters per Mosaic value to the required number, say 100, from its default value of 20 and click OK.
    Image of the Mosaic Dataset Properties dialog box
  4. Restart the map service and generate the cache tiles.

Article ID:000011325

Software:
  • ArcGIS Server

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic