English

Bug: Upgrade to a 10 release geodatabase does not identify invalid coded value domains, which may result in application crash following the upgrade

Description

The 10.0 geodatabase upgrade operation is not identifying certain invalid attribute domains and flagging them prior to the upgrade. Although a successful upgrade occurs, the user may experience crashes when trying to preview feature classes following the upgrade.

Cause

This is caused by coded value attribute domains containing coded values which are missing their corresponding descriptions. Creating coded value domains with this missing information was possible prior to the fix for NIM003107, which was included in ArcGIS 9.2 and ArcGIS 9.1 SP3.

Workaround

NIM063593 is fixed in ArcGIS 10.0 SP2 and results in the following error being raised during the upgrade operation when an invalid domain is encountered:

"Error(Check Datasets): Domain is corrupt ([Name of domain]).
Error(Check Datasets): The name of an entry in the CodedValueDomain is empty. [domain name: [Name of domain]]"

    Related Information