English

Problem: Unable to create or upgrade a user schema geodatabase in Oracle due to insufficient privileges

Description

When creating an ArcSDE 10 user schema geodatabase in Oracle, or upgrading an existing one to version 10, a message is returned indicating that the user does not have sufficient privileges to perform the operation.

Cause

This is a known issue.

The software checks for required SDE user privileges to create and upgrade a geodatabase. When the software does not find the ADMINISTER DATABASE TRIGGER privilege, the process fails.

The ADMINISTER DATABASE TRIGGER privilege is not required for non-SDE users. The software should not require this privilege to complete geodatabase creation or upgrade.

Solution or Workaround

Grant the ADMINISTER DATABASE TRIGGER privilege to the schema owner before creating or upgrading a geodatabase in the user's schema.