ERROR

PMF: Unable to read the specified document

Last Published: April 26, 2020

Error Message

When attempting to publish a map service using either ArcGIS Server Manager or ArcCatalog, the following error is displayed:

Error:   
PMF: Unable to read the specified document.

Cause

This error is a generic message that may appear when ArcGIS Server is unable to start a map service.

Possible reasons for this error include:

  • The map document being published was built in a later version of ArcGIS Desktop than the current version of ArcGIS Server, and was not saved as an earlier version before publishing.
  • The ArcGISSOC account may not have permission to access the COM component esriSystem.esriAppLockMgr.
  • Custom extensions used in the map document may not be installed on the ArcGIS Server machine.

Solution or Workaround

The solutions for the three scenarios detailed above include:
  • In the case where the map document was built using a later version of ArcGIS Desktop than the version of ArcGIS Server used to publish the document, open the map document in ArcGIS Server and, from the File menu, choose the option to 'Save a copy'. Save the map document to the current version of ArcGIS Server using the 'Save as type' drop down at the bottom of the 'Save a Copy' dialog.
  • In the case where COM component access issues are suspected, check the System logs in the Windows Event Viewer for DCOM errors or warnings related to the ArcGISSOC account. If DCOM errors are found:
  1. On ArcGIS Server, navigate to Start > Programs > Administrative Tools, and double-click Component Services to open the Component Services console.
  2. Browse to Console Root > Component Services > Computers > My Computer > DCOM Config.
  3. Right-click on esriSystem.esriAppLockMgr and choose 'Properties'.
  4. Click the Security tab. Ensure that the ArcGISSOC account has full control of the component in both the 'Launch and Activation' and 'Access Permissions' access control lists.
  • In the case where custom ArcGIS Desktop extensions are suspected as the cause for this issue, open the map document in ArcGIS Desktop. Open the Extensions dialog.
    Note:
    In ArcGIS Desktop 9.3.1 and earlier versions, go to the Tools menu and select Extensions.
    Note:
    In ArcGIS Desktop 10, go to the Customize menu and select Extensions.
    Uncheck any extensions that are not enabled on ArcGIS Server, and remove any toolbars associated with those extensions. Save the document and republish.

Article ID:000011066

Software:
  • ArcGIS Server

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