English

Error: Correct version of ArcGIS isn't installed

Error Message

When installing Business Analyst 9.3.1, the following error message is displayed:

"Correct version of ArcGIS isn't installed".

After clicking the error link, the following message is displayed:

"ArcGIS 9.3.1 Desktop must be installed prior to the installation of Business Analyst 9.3.1. Please insert Business Analyst DVD #1 and execute the "setup.exe". Follow the on-screen install instructions to complete the installation of Business Analyst."

Cause

Business Analyst Desktop 9.3.1 does not install if ArcGIS Desktop 9.3.1 Service Pack 1 is installed. This Registry fix applies for all subsequent ArcGIS 9.3.1 Service Pack releases.

Solution or Workaround

Modification of the Windows registry is required.

Warning:
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

ESRI cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.


To modify the Windows registry:

  1. Download the .zip file that is applicable to your operating system.
    · fixreg32.zip contains the .reg file for 32-bit operating systems
    · fixreg64.zip contains the .reg file for 64-bit operating systems

  2. Unzip the file to the local machine where ArcGIS is currently installed.
  3. On the local machine, double-click the appropriate .reg file. This action applies the changes to the registry.