English

How To: Split a circle polygon in half in ArcMap

Summary

Instructions provided describe how to split a circular polygon precisely in half through its center.

Procedure

The first part of the procedure describes how to create a point feature at the center of a circle. The second part of the procedure describes how to split the circle with a line through the center point.

In ArcInfo, the 'Feature to Point' tool in ArcToolbox is used to create a point feature class from the centroids of polygons. However, if that tool is not available, another way to create a point at the circle's center is to follow step 1 below. After these central points are created, using whichever method is available, perform step 2 below.

  1. Create a point feature at the center of a circle

    (a) Make sure the polygon feature class is in a projected coordinate system. If it is in a geographic coordinate system (latitude/longitude), run ArcToolbox > Data Management Tools > Projections & Transformations > Feature > Project, to re-project the feature class to a projected coordinate system (one that uses linear units such as meters or feet).

    (b) In the polygon layer attribute table, add two new fields of type 'Double Precision' (for example, 'DblX' and 'DblY'). Right-click the DblX field name > Calculate Geometry > Property: 'X Coordinate of Centroid,' 'Use coordinate system of the data source,' and set Units corresponding to the units of the data source.

    (c) Click OK to calculate. Do the same for DblY (Properties: Y Coordinate of Centroid). Now there are columns of X and Y values for the centroids of each polygon in the feature class.

    (d) Open the polygon layer attribute table.

    (e) From the Options menu, click Export and browse to a location on disk to create either a .dbf file or a table in a geodatabase.

    (f) From the Tools menu, click Add XY Data and browse to the new table. Set the X Field to DblX, and the Y Field to DblY from the table.

    (g) Click Edit > Import to set the coordinate system to that of the polygon feature class.

    (h) Click OK to bring in the XY values as a point layer. This is now an 'event' (temporary) layer in the map. To export the layer to make it permanent, right-click the layer > Data > Export Data.

  2. Split the circle with a line though the center point

    (a) Start an editing session on the polygon layer.

    (b) Set snapping to the new point layer vertices.

    (c) Set the task to Cut Polygon Features.

    (d) Highlight the circle to be bisected.

    (e) Click the Sketch (pencil) tool.

    (f) Click outside the circle feature (but close to it) to bisect. This point determines the angle of the line that bisects the circle through the center point, so select an appropriate location.

    (g) Mouse-over the point at the center of the circle until it snaps to the point, but do not click on the point. Instead, right-click the mouse and select 'Direction...' to bring up the direction control. Press Enter to accept the angle displayed in the direction control. The cutting line origin is now the point at which the mouse was left-clicked.

    (h) Move the mouse across the circle so that the cutting line follows the mouse to the opposite side. The line is extended and constrained to the specified angle. When it extends through the circle and out the other side, double-click the mouse outside the circle to complete the line. This creates a line that begins and ends on the boundary of the circle and goes through the centroid, bisecting the circle. The two halves of the circle will flash, showing they have been cut. The result is two half-circle polygons.

Related Information