English

Error: [ERR0402] Open site error: The site requested cannot be opened. It is not compatible with the current version of ArcIMS

Error Message

After upgrading to a different version of ArcIMS, the ArcIMS Administrator cannot be opened and the following error message appears:

"[ERR0402] Open site error:
The site requested cannot be opened.
It is not compatible with the current version of ArcIMS."

Cause

The .jar files located in Program Files\ArcGIS\ArcIMS\Jre\Lib\Ext are used to run the ArcIMS Administrator application. The original install of ArcIMS copies the entire Ext folder including all the .jar files to the Jre\Lib subfolder of the active Java Runtime Environment (JRE) or Java Development Kit (JDK). When an update is applied, these .jar files may or may not be updated. If they are not updated, the new version of ArcIMS will not match the version of the .jar files, and an error appears when ArcIMS Administrator is opened.

Solution or Workaround

In most cases, running the ArcIMS Post Install and selecting the JRE Configuration option copies the updated .jar files to the selected Java Jre\Lib\Ext folder.

  1. Click Start > Programs > ArcGIS > ArcIMS > ArcIMS Post Install.
  2. Select Custom and click Next.
  3. Check the ArcIMS JRE Configuration option. The other configuration options are not necessary to resolve this issue.
  4. Browse to the Java Runtime Environment location, if it is not already specified, and click Next.
  5. Click Finish to complete the Post Install.

    Note:
    If the same error still exists when trying to run ArcIMS Administrator, rename or remove the Program Files\ArcGIS\ArcIMS\Jre\Lib\Ext folder and run a repair on ArcIMS from the Add/Remove Programs in the Control Panel. Once the repair is completed, repeat Steps 1-5.

Related Information