English

FAQ: Can Microsoft Visio 2007 be used as a CASE tool for geodatabase schema design?

Question

Can Microsoft Visio 2007 be used as a CASE tool for geodatabase schema design?

Answer

Yes, Microsoft Visio 2007 can be used as a CASE tool for geodatabase schema design. Microsoft Visio 2007 Service Pack 2 is required. For more information, see a description of the service pack and associated language pack.

Unified Modeling Language (UML) diagrams that define geodatabase schema can be created in Microsoft Visio 2007. These diagrams can be exported as an XMI file, and imported into an empty geodatabase with the Schema Wizard tool in ArcCatalog.

Refer to the following documentation for more information on building geodatabases with CASE tools.

Microsoft Visio 2003 had an option in the user interface (UI) to incorporate Add-On functionality. This was used to export the UML diagrams as XMI files. However, in Microsoft Visio 2007, the Add-On functionality is no longer available in the UI. This functionality can be accessed programmatically through the Microsoft Visio 2007 API. Users must add custom code (provided in this document as a download) loaded as a new Module, to enable the Add-On functionality and execute the XMI export tool.

Two workflow scenarios are described below:

Scenario 1: Creating a new UML diagram using the ESRI Visio 2003 template

1. Uninstall the current version of Visio and install Visio 2007 Professional.
2. Download and install Visio 2007 Service Pack 2.
3. Download the ESRIExportToXml.bas file.
4. Use the Visio 2003 template to create a new UML diagram.
5. When the UML diagram is complete and it is ready to be exported as an XMI file, select Tools > Macros and open the Visual Basic Editor.
6. In VBE, select the Modules folder and right-click to display the context menu. Select the Import File menu and browse to the directory where the ESRIExportToXml.bas was saved and select to open the file.
7. In VBE, save the project. If the existing UML diagram was created from a previous version of Visio, Visio 2007 displays a message prompting a version to save the UML diagram into. Select the current version.

Note:
Once the project is saved, it may be necessary to restart Visio 2007 for the new macro to display properly.


8. To export the UML diagram to XMI, select the Tools > Macro context menu and a new menu called 'ESRIExportToXml' displays. Select this menu to export the UML diagram to XMI.

Scenario 2: Using an existing UML diagram

1. Uninstall the current version of Visio and install Visio 2007 Professional.
2. Download and install Visio 2007 Service Pack 2.
3. Download the ESRIExportToXml.bas file.
4. Open an existing UML diagram.
a. There is a possibility that the ESRI export to XML macro may already exist in the existing UML diagram. If this is the case, it may be necessary to remove the old module and import the ESRIExportToXml.bas file.
b. If the macro does not exist, the new macro must be imported.
5. Select Tools > Macros and open the Visual Basic Editor.
6. In VBE, select the Modules folder and right-click to display the context menu. Select the Import File menu and browse to the directory where the ESRIExportToXml.bas was saved and select to open the file.
7. In VBE, save the project. If the existing UML diagram was created from a previous version of Visio, Visio 2007 displays a message prompting which version to save the UML diagram into. Select the current version.

Note:
Once the project is saved, Visio 2007 may have to be resaved for the new macro to display properly.
8. To export the UML diagram to XML, select the Tools > Macro context menu, and a new menu called 'ESRIExportToXml' displays. Select this menu to export the UML model to XML.

Download the ESRIExportToXml.bas file.

Note:
While ArcGIS supports the use of CASE tools to import UML diagrams for geodatabase schema design, support for all geographic data types, relationships, and behaviors is not complete in UML data modeling.


To review the level of geodatabase schema design support in ArcGIS, review the following note about the use of UML for geodatabase design.

Be advised that Microsoft has indicated that the Visio product is not a recommended tool for UML design: Visual Studio 2005 Team System Modeling Strategy and FAQ.


Note:
The ESRI MS Visio 2007 template is not currently available. Continue to check the ESRI Support Center Data Model Tips and Tricks site for updates.