English

How To: Create a buffer around a point feature and use it to extract attributes from an overlapping polygon feature class

Summary

Instructions provided describe how to create a buffer around a point feature and use it to extract attributes from an overlapping polygon feature class. In most cases, the buffer does not encompass whole polygons, the procedure allows for calculating the percentage of a polygon the buffer encompasses, and then dividing the data by that percentage.

Example: The total population within one mile of a point is desired. The current data is a census polygon feature class containing population values for each polygon feature. The one-mile buffer around the point crosses 30% of a polygon with a population of 100, and 40% of a second polygon with a population of 10; therefore, the total population within the 1 mile buffer is 34:

(30%(100))+(40%(10))= 34


Note:
This procedure assumes that attribute data is spread evenly across a polygon feature.


Note:
The entire process can be created inside of a model.

Procedure

It is required that each point and polygon feature is given a unique identifier. If it is Object ID (OID), create a new field to calculate the OID values within, as the OID can change with these processes.

  1. Open ArcMap. Add the point and polygon shapefiles or feature classes to ArcMap.
  2. Open the Buffer (Analysis) Geoprocessing tool from ArcToolbox. Set the input to the point shapefile. Name the output (BufferA in this example). Set the linear unit and buffer distance. Click OK.
  3. If the data is in a projected coordinate system, skip to the next step. If not, continue. In ArcMap, click View > Data Frame Properties > Coordinate System tab. In the Select a Coordinate System dialog box, select Predefined > Projected Coordinate Systems > Continental > North America > USA Contiguous Albers Equal Area Conic. Click OK.
  4. In the ArcMap Table of Contents, right-click the polygon shapefile > Open Attribute table. Click Options > Add Field. Name the field 'TotArea', set the type to Double. Click OK.
  5. In the polygon shapefile attribute table, right-click on the field TotArea > Calculate Geometry. Set the Property to Area. Set the Coordinate system to a Projected Coordinate System. Set the linear unit, and note it for a later step. Click OK and close the attribute table.
  6. Open the Intersect (Analysis) Geoprocessing tool from ArcToolbox. Set the input to the polygon shapefile and the BufferA (result from the buffer) shapefile. Set the output location and name ('IntersectA' for this example). Click OK.
  7. In the ArcMap Table of Contents, right-click the IntersectA shapefile (result from the Intersect tool) > Open Attribute table. Click Options > Add Field. Name it 'Area', set the type to Double. Click OK.
  8. In the IntersectA shapefile attribute table, right-click on the field Area > Calculate Geometry. Set the Property to Area. Set the Coordinate system to a Projected Coordinate System. Set the linear units to be the same as was used in Step 5 to calculate TotArea. Click OK.
  9. In the IntersectA attribute table, click Options > Add Field. Name it 'Percent', set the type to Double. Click OK.
  10. Right-click on the field Percent > Field Calculator. Enter: [Area]/[TotArea] and click OK.

    Note:
    All of the values should be between 0 and 1.

  11. Add a new field for every field in the polygon shapefile or feature class that needs to be divided proportionately.

    Note:
    For example: If the population field needs to be divided by the proportion of the buffered area covers it, create a new Double type field to calculate that proportioned value.

  12. Right-click on one of the fields that was just created > Field Calculator. Enter the field name of the source field (i.e., the population field), and multiply it by the Percent field. For example:

    [Population]*[Percent]

    Repeat this step for each of the fields created in the previous step. Close the attribute table.
  13. Open the Dissolve (Data Management) Geoprocessing tool from ArcToolbox. Set the input as IntersectA. Set the output name and location ('DissolveA' in this example). Set the Dissolve field to the original point shapefile's unique identifying field. Set the Statistics fields to each of the fields created in the previous steps that contain the proportions the data, and set the type to Sum. Click OK.