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Error: ArcSDE for Informix post installation, ERROR: -329; Database not found or no system permission

Error Message

During post installation of ArcSDE for Informix (first PI step), the following error is displayed:

"ERROR: -329; HY000 : [Informix][Informix ODBC Driver][Informix]Database not found or no system permission."

The following error is subsequently displayed:

"Error - SQLExecDirect failed."

Trying to connect with dbaccess displays the following error:

"329: Database not found or no system permission.
178: ISAM error: Database is locked; pending change to logging mode."

Cause

The Informix database logging mode needs to be changed. ArcSDE requires logging or buffered logging.

Solution or Workaround

Use the ondblog command to alter the database logging mode:

  • C:\IFMXDATA\DATA>ondblog buf -f sde_chunk sde
    Syntax for ondblog:
    C:\IFMXDATA\DATA>ondblog
    ondblog
    ondblog usage
    =============

    ondblog <new mode> [-f <filename>] [<database list>]

    new mode:
    buf - Change database to buffered mode.
    unbuf - Change database to unbuffered mode.
    nolog - Change database to no logging. (not in EDS)
    ansi - Change database to be ANSI-compliant
    cancel - Cancel logging request.
    -f <filename> File containing list of databases for logging change.
    <database list> List of databases for logging change.
    ondblog complete, returning 6 (0x06)