English

How To: Access the ArcGIS Java Help System content from within Eclipse Developer IDE for Windows Developers

Summary

Instructions provided address the Eclipse Java Help System (JHS) Developer Plug-in that ships with ArcGIS Engine/ArcGIS Server and are in response to the Eclipse Developer IDE hanging on the install of the documentation plug-in.

Packaging the Java Help System as a Developer IDE Plug-in can significantly increase memory size requirements and cause the Developer's environment to hang on install. Help in the Eclipse Developer IDE is like the rest of the environment in that it is built with a plug-in architecture.

This article also discusses taking advantage of the JHS InfoCenter as a stand-alone Help System, to be integrated into an Eclipse Developer Environment.

Procedure

There are two options to resolve this issue:

1. Manually install the documentation plug-in by unpacking the plug-in archive and manually copying the files to the plug-in location.

2. Automatically allow Eclipse to integrate the Help System using Remote Help. This is the preferred option: install the Java Help System (JHS) and then run it in InfoCenter or Server mode, allowing the JHS to be hosted by a Web Server on a specific port where a developer can easily integrate into an Eclipse Developer environment. For more information, go to the ArcObjects Development Blog topic: Accessing ArcGIS Java Help System Content from within Eclipse Developer IDE for Windows Developers.

Before getting started, ensure that the ArcGIS SDK Java Help System is installed. This is a separate install from the ArcGIS Engine and/or ArcGIS Server for Java products. Once successfully installed, the Help System is run in a single user mode as a stand-alone Help System for the Java Developer.

To set up the JHS in InfoCenter mode on Windows, execute the Java Help Server scripts located at '%ARCGISHOME%\java\ docs\'. To start the JHS in InfoCenter mode, execute the ‘startJavaHelpServer.bat’ file:

 %ARCGISHOME%\java\docs\startJavaHelpServer.bat [<port>] 


The default port for the JHS InfoCenter is ‘2112’ if the port is not set when the script is executed. Clients can now access the JHS from any machine inside the network by pointing their Web browser to the following URL:

%ServerName%:2112\help\index.jsp


Once the JHS has been successfully started in InfoCenter mode, it is easy to integrate the Help System into the Eclipse Developer IDE.

Make sure the latest supported Eclipse developer IDE, version 3.2.2, is installed and open the Preferences dialog box by selecting ‘Window > Preferences’ from the tools menu. In the Preference dialog box, navigate to ‘Help > Content’ as shown below:
[O-Image] Preferences

The Eclipse Help System needs to know the address (host/IP) and port of the remote server to integrate with the local system. Select the 'Include help content from a remote infocenter' checkbox and provide the following server information:
[O-Image] Specify a host name
1. Host: Put a valid Server Name or IP Address where the remote infocenter is located. In our example the server name is 'javabuild'.
2. Path: '/help'.
3. Select the 'Use Port' radio box and put '2112' in the port text box. The dialog box should resemble the image below with the server name being used replacing 'javabuild'.


[O-Image] Preferences
Click 'OK' to close the Preference dialog box and open up the Eclipse Help System, 'Help > Help Contents', to see the ArcGIS Java Developer Help System integrated into the local Eclipse Help System.


[O-Image] Help - Eclipse Platform
The JHS InfoCenter is a stand-alone server and does not require an additional Web Server. However, in a production environment, it may be necessary to control important issues that are best handled by a Web Server.

For example, requests may be redirected by setting up a proxy module in Apache. This is all possible for more advanced users of the JHS InfoCenter.