English

FAQ: Are ArcSDE 9.3 and 9.2 commands interoperable with ArcSDE 9.2 or 9.3 geodatabases?

Question

Are ArcSDE 9.3 and 9.2 commands interoperable with ArcSDE 9.2 or 9.3 geodatabases?

Answer

Yes, with a few exceptions.

· If a particular option is not available in both releases, it is not interoperable.

For example, the migrate operation was added to sdetable and sdelayer at the version 9.3 release, so it cannot be used against an ArcSDE 9.2 geodatabase. Other examples include the following:

- Any DBMS-specific option for a database that is not supported in the release being used is not supported. For instance, -m update_db_schema cannot be used with the 9.2 version of sdetable -o update_dbms_stats to update the statistics in an ArcSDE 9.3 geodatabase in PostgreSQL.
- The 9.3 version of sdesetup -o delete cannot be used to delete a user-schema geodatabase from a 9.2 geodatabase in Oracle.
- The -s option cannot be used with the 9.2 version of sdeservice, because the option was not added until 9.3.
- The 9.2 version of sderaster -o export cannot export to GeoTIFF, because this is not supported until the release of version 9.3.

· The 9.2 sdesetup command cannot be run against a 9.3 geodatabase, since downgrading a geodatabase is not supported.

· If a direct connection is being used to connect to the geodatabase (for example, direct connect syntax is passed with the -i option), the appropriate direct connect drivers must be installed on the machine from which the ArcSDE command is being executed.

That means, if making a direct connection from a 9.2 service pack 5 or service pack 6 administration command to an ArcSDE 9.3 geodatabase, the ArcGIS 9.3 geodatabase direct connect for 9.2 client's setup must be run to install the ArcSDE 9.3 direct connect drivers. This setup can be obtained from the ArcSDE download page on the ESRI Support site.

If making a direct connection from a version 9.3 administration command to an ArcSDE 9.2 geodatabase, the ArcGIS pre-9.3 geodatabase direct connect setup must be run to obtain the ArcSDE 9.2 direct connect drivers. This setup is provided on client installation media.

Related Information