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Error: Closed polylines are not allowed for network features

Error Message

There are three scenarios under which this error can occur:

Scenario 1 - When using XML Import or the Extract Data and Create Replica commands on the Distributed Geodatabase toolbar, if the source features are geometric network features, the operation may fail and display the closed polyline error message.

Scenario 2 - During conflict resolution with the Conflicts Dialog.

Scenario 3 - During reconcile, in which the error message is appended to the end of a "The version failed to reconcile." error. The error message may or may not be appended with information concerning the class name and Object ID of the feature causing the error.

Cause

If the error is occurs during Scenario 1, the operation is failing because of the presence of closed polylines (polylines with the same start-stop vertex) within the source geometric network feature classes. These features are invalid within the geometric network; therefore, they are flagged as build errors during network creation.

Refer to the following link for more information: Identifying Geometric Network Build Errors.

If the error is encountered during Scenarios 2 or 3, it is most likely due to the geometry for an edge element collapsing on itself and forming a polyline or geometry with a length of zero or a geometry whose end points are snapping to one another. The geometry may correspond to an entire edge feature or to a segment of a complex edge feature.

Solution or Workaround

Depending on the action that caused the error message, the solution to the issue may vary.

  • Scenario 1 - Correct the geometry of the features in the source network feature class using the steps outlined in the Desktop Help topic 'Repairing geometric network connectivity', and follow the directions under the section titled: 'Repairing features with an identical start-stop vertex'.

    The Desktop Help topic can be found at the following link: Repairing geometric network connectivity.
  • Scenario 2 may be resolved if it is possible to determine which feature is raising the error by resolving conflicts at a class or feature level. If determined,
    1. Use the Disconnect command on the feature prior to resolving the conflict.
    2. Determine if the feature has inconsistent connectivity and use the Rebuild Connectivity tool over the feature.
    3. Assess whether the replacement is necessary or if it can be done in the parent version following the post.

    If this error is unresolved, contact Technical Support to troubleshoot this issue.
  • Scenario 3 may be resolved if it is possible to determine which feature is raising the error by resolving conflicts at a class or feature level. If determined, use the Disconnect command on the feature prior to reconciling the version.

    If this is not successful, the assistance of Technical Support may be required.