PROBLEM

Business Analyst 'Preferences' disappears or displays an error after uninstalling Business Analyst Server

Last Published: April 25, 2020

Description

After uninstalling Business Analyst (BA) Server and selecting Business Analyst 'Preferences' from the BA Toolbar in BA Desktop, Business Analyst 'Preferences' disappears or displays an error.

Cause

This occurs if Business Analyst Desktop and Business Analyst Server are installed on the same server and one or more Business Analyst Server components are uninstalled. This is because Business Analyst Server 'Desktop_Components_Setup' updates some Business Analyst desktop components, so if the BA Toolbar is launched and Business Analyst 'Preferences' is selected after these components are uninstalled, then the BA 'preferences' can indicate an error.

Solution or Workaround

Re-install Business Analyst Desktop build 303 (Service Pack 1).

Launch Business Analyst Desktop to view the Business Analyst Preferences in BA toolbar.

Article ID:000009878

Software:
  • ArcGIS Business Analyst Enterprise

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