English

Problem: Creating a multiversion view fails with 'Table is not multiversion...'

Description

Creating a multiversion view returns the following error:

"Error: Table is not multiversion, but must be for this operation (-178).".

Code:
C:\>sdetable -o create_mv_view -T parcels_view -t parcels -i 5151 -u sde -p sde

ArcSDE 9.2 for Oracle10g Build 449 Wed Jan 16 12:20:02 2008
Attribute Administration Utility
-----------------------------------------------------
Error: Table is not multiversion, but must be for this operation (-178).

Error: Unable to create MV view parcels_view for table parcels.

Cause

To create a multiversion view requires the table or layer to first be registered as versioned. If the table or layer is not registered as versioned, one will encounter the above error.

Solution or Workaround

Multiversion views require the underlying table or layer to first be registered as versioned.

One can register a table or layer as versioned in ArcGIS by using ArcCatalog. Select the data source, right-click to open the context menu, and select the 'Register As Versioned...' command.