English

Error: Server library could NOT be loaded

Error Message

For direct connects to work from a 9.2 or older version, ArcSDE and ArcGIS Desktop should be at the same version and service pack level. If there is any mismatch in terms of version and service pack, direct connect fails with the following error message:

"Sever library could NOT be loaded".

Cause

The ArcGIS Desktop and ArcSDE version and/or service pack could be different. This cause is applicable to 9.2 or older versions.

Solution or Workaround

Run the Service Pack Finder (available in the Service Pack Web site) on the client and server machine.

If there is a mismatch between ArcSDE and ArcGIS Desktop, apply the necessary service packs.

Related Information