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Problem: ArcGIS Server postinstallation hangs when pre-existing services have large caches

Description

When running the ArcGIS Server postinstallation on a system where ArcGIS Server has been previously installed, the ArcGIS Server Post Install hangs if the server has map or globe services with large associated caches located in the default location.

Cause

Caches are built for Map and Globe services in ArcGIS Server to increase performance by serving pre-created tiles directly from a Web server. These caches consist of files inside a cache directory, by default C:\arcgisserver\arcgiscache. Caches may contain very large numbers of cache files. If the ArcGIS Server postinstallion is run after creating a cache in the default location, then the permissions for every file under C:\arcgisserver are updated. This can take a long time and the ArcGIS Server postinstallion appears to hang during this time.

Solution or Workaround

The following steps outline how to prevent the ArcGIS Server postinstallion from needing to change the file permissions of every file in default-located caches by using operating system tools.

  1. Stop the ArcGIS Server Service.

    a) Navigate to Start > Settings > Control Panel > Administrative Tools > Services.
    b) Select the ArcGIS Server Object Manager service and click Stop.
    c) Close the Services dialog box.

  2. Rename the directory containing the ArcGIS Server server directories. This directory is C:\arcgisserver by default. For example, rename it to C:\arcgisserverBackup. Use Windows Explorer or a command prompt to rename the folder.

    Note:
    This breaks any UNC shares previously configured; reestablish them in step 8, below.

  3. Run the ArcGIS Server postinstallation. For more information on the postinstallation, see the Install.htm page on the ArcGIS Server installation CD.
  4. Log out of Windows and log back in.
  5. Stop the ArcGIS Server service as it has been re-started by the ArcGIS Server postinstallation.

    a) Navigate to Start > Settings > Control Panel > Administrative Tools > Services.
    b) Select the ArcGIS Server Object Manager service and click Stop.
    c) Close the Services dialog box.

  6. Delete the ArcGIS Server cache directory created by the ArcGIS Server postinstallation.
    This is C:\arcgisserver\arcgiscache unless it was changed in step 3.

    Note:
    It is very important to NOT delete the ArcGIS Server Directories parent directory, C:\arcgisserver, by default.

  7. Move the cache sub-directory of the directory renamed in step 2 back to the location used during the postinstallation in step 3, C:\arcgisserver by default.

    For this example, move
    C:\arcgisserverbackup\arcgiscache to C:\arcgisserver\arcgiscache

    Note:
    Even though the move process happens instantaneously, it may take some time for the permissions inherited by the moved files to propagate to all files in the caches. If the cache is inaccessible even after performing step 9, wait some additional time, then re-start the affected Map or Globe services.

  8. If UNC shares for the ArcGIS Server directory sub-directories were broken in step 3, re-establish them now.
  9. Start the ArcGIS Server Service as described in step 1.