English

FAQ: Installing ArcGIS Server changes the .Net primary version to .Net 2.0

Question

Installing ArcGIS Server changes the .Net primary version to .Net 2.0

Answer

ArcGIS Server for the Microsoft .Net Framework requires that ASP.NET 2.0 be registered with Microsoft IIS. ASP.NET 2.0 needs to be registered with IIS so that you can work with Web Applications and the Web ADF controls and classes, which have been designed to work with the Microsoft .NET Framework 2.0.

If ASP.NET 2.0 is not registered with Microsoft IIS, the ArcGIS Server install will inform you of this problem and will re-register ASP.NET 2.0 for you, making it the primary version.

The message from the installation is:

ArcGIS Server for the Microsoft .NET Framework requires ASP.NET 2.0 to be registered with Microsoft IIS. Selecting Next to continue this installation will re-register ASP.NET 2.0 with IIS.

This change applies to all existing applications; the install cannot distinguish between applications that were and were not built with ESRI software.

For more details, see the information on the ASP.NET IIS Registration Tool (aspnet_regiis.exe) from the Microsoft website.